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2Manipulating Documents
This chapter presents information about Informed documents and how they are manipulated.
learn about Informed document types and password security, as well as how to create, open
and save form template documents.

Informed Documents
The term document refers to a file that contains information. An Informed document is a file tha
contains information about a form. There are four types of Informed documents: form templa
documents, form data documents, package documents, and interchange documents.

Form Template Documents (.ITP)

A form template document contains a form template. A form template is the layout or framewo
a form that you create using Informed Designer. It contains all the intelligent features of the fo
well as its graphic elements. The Informed Filler user fills out a form by entering values in the
on the template. In order to use a template with Informed Filler, the user must place the temp
his or her templates folder.

Form Data Documents (.IFM)

A form data document contains only a form’s data. When the Informed Filler user fills out form
the information entered is stored in a form data document. A single form data document can
one or more completed forms. Each completed form is stored as a record. Each form data do
also contains a template ID. The template ID identifies which template is needed to display a
manipulate the form data.

Package Documents (.IPK)

A package document combines a form template and its associated data. It is created using In
Filler and is used primarily when a user mails a form to someone who doesn’t have the corre
ing template. When the Informed Filler user opens a package using Informed Filler’s Open c
mand, the data document and template (if needed) are extracted. If the user’s templates fold
not already contain the template, the one extracted from the package is copied there and op
The data document is opened as an untitled document that can later be saved in a new file.

Interchange Documents (.IIF)

Informed Interchange documents contain all the data for one or more completed forms (or records), 
and are used primarily for transferring information between different applications, and differe
versions of Informed. They are created and read using Informed Filler, and store all types of 
mation including stylized text values, pictures, signatures, and annotations.

Informed Documents
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Creating a New Template
The New command creates a new form template.

To create a new template, choose New from the File menu. A new untitled window appears.   

You can create as many documents—or open as many existing ones—as you like. You are o
ited by the amount of available RAM (random access memory) in your computer.

Each new document is assigned a set of default settings. These defaults refer to the current 
of the object tools; that is, they determine what new objects will look like. For example, the de
font for the text tool is Arial (Windows) or Helvetica (Mac OS). Similarly, the line tool has a def
width of one point. See Appendix A for a complete list of default settings.

Template Information
Since templates and data documents are separate files, there needs to be a way to identify w
template is used for a particular data document. Informed Designer’s Template Information c
mand allows you to enter information that identifies a particular template. This information 
includes a template name, template ID, and revision number.

Creating a New Template

Template Information
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To enter or view template information, choose Template Information... from the Form menu. The 
Template Information dialog box appears.

Type a name for the template in the ‘Template name’ text box. The name that you enter can b
descriptive than the filename of the template. This can be helpful for templates that are store
accessed using Windows computers where file names are limited to a length of eight charac

The Unique template ID provides a means of linking form data documents to form template d
ments. When the Informed Filler user creates a new data document, in addition to the form d
itself, the template ID of the template used is also stored in the data document. When Inform
Filler opens a data document, the template ID is used to identify and locate the correct temp
use.

To enter a template ID, type a value in the ‘Unique template ID’ text box. It is recommended 
you assign a meaningful ID. For example, if you create an expense form template for claimin
expenses in US dollars, you might assign a template ID of ‘Exp-USD-96,’ whereas a templat
claiming Canadian dollar expenses might be assigned ‘Exp-CDN-96.’ If you don’t specify a te
plate ID, Informed Designer assigns a random number for you the first time you save the tem

The revision number further identifies the template. If you don’t enter a value in the ‘Revision 
ber’ text box, Informed Designer assigns the revision number “1” when you save the template
the first time.

Note The template ID and Revision number provide a means of coordinating the distribution of n
templates and new revisions of existing templates using Informed’s built-in forms distributio
capabilities. For details on these capabilities and the importance of the template ID and rev
number, see Chapter 8 of your Informed Designer Forms Automation manual.
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The Author section of the Template Information dialog box contains two text boxes: ‘Name’ a
‘Organization.’ You can use these text boxes to store information that identifies the designer o
form template.

You can also enter a brief description of the template in the ‘Description’ text box. Entering a
description of the template can be helpful to both the Informed Filler user and other form des
who might have to revise the template in the future.

Changing the Password
As a security measure, you can use passwords to prevent other users from opening and cha
templates with Informed Designer. If a template has a non-blank password, you’ll be prompte
enter it when you attempt to open the template using Informed Designer’s Open command (s
“Opening a Template” later in this chapter).

To change the password for a template choose Preferences... from the Edit menu. When the Pref-
erences dialog box appears, click the Security icon in the scrolling list. The dialog box chang
show the Security preferences panel.

Click the ‘Set Password’ button to display the Set Password dialog box.

Note Chapter 7 of your Informed Designer Forms Automation manual explains how you can autho-
rize and verify templates to ensure their authenticity. It is important to note that entering yo
name in the Author section of the Template Information dialog box is not the same as auth
ing a template by using the Authorize command.

Changing the Password
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If you haven’t entered a password before, only the ‘New password’ and ‘Confirm password’ te
boxes are available. If a password already exists, the ‘Old password’ text box is also availabl

If a password already exists, you must enter that password in the ‘Old password’ text box. Ty
your new password in the ‘New password’ text box, then press Tab. The insertion point move
the ‘Confirm password’ text box. Type the password again, then click ‘OK.’ Informed Designer
display a message confirming that you have successfully changed the password.

Opening a Template
The Open command opens an existing template.

To open a template, choose Open... from the File menu. If you’re using a Windows compatible 
computer, you’ll see the standard Windows Open dialog box.

If you’re using a Mac OS compatible computer, you’ll see the standard Mac OS Open dialog

Opening a Template
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Select a template to open, then click ‘Open.’

If the template you’ve selected has a non-blank password, you’ll be asked to enter it.

Informed Designer will not open the template until the correct password has been entered.

For information about how to change your password, see “Changing the Password” earlier in
chapter.

While the template is opening, Informed Designer displays progress information at the lower
corner of the drawing window.

Note You can make the Open dialog box appear automatically when you run Informed Designer
holding down the Alt (Windows) or Option (Mac OS) key after double-clicking the applicatio
icon.

Note Passwords are case sensitive. This means that upper and lower case letters are considere
different. Be sure to check whether or not your Caps Lock key is pressed.
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After a template is opened, its name appears in Informed Designer’s Window menu. 

A checkmark appears next to the name of the active template. To make another template the
template, simply click its window, or choose its name from the Window menu.

Missing Fonts

When you open a template, Informed Designer checks to make sure that the fonts used on t
plate are available in your system. Different systems on different computers can have differen
installed. If you draw a template on one computer, then transfer it to different computer, that 
puter might not have the fonts that you originally used to draw the template.

If Informed Designer detects that at least one font is missing from your system, you’ll see the
lowing dialog box.

Any text that uses one of the listed fonts will display using a font that’s available in your syste
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Opening a Locked Template

If the template you choose to open is locked, or resides on a locked disk, Informed Designer
warn you.

If you continue, the template will be opened as usual. However, you won’t be able to save an
changes (the Save command will always be disabled). To save any subsequent changes ma
template, choose Save As... from the File menu to save the template in a new file.

Opening a Template in Use

A template document that is presently in use cannot be opened. Most commonly, if a templa
already in use, you’ve probably already opened it yourself in Informed Designer or Informed F
If you try to open a template already in use, you’ll see a dialog indicating so.

You cannot open a template that resides on a file server and is being used by another user. 
attempt to do so, a dialog appears giving you the options of waiting until the template is avai
for use, or of canceling the Open command.

Closing a Template
The Close command closes the currently active template document—that is, the document th
responds to the front-most drawing window on your screen.

To close the currently active template, choose Close from the File menu, or click the window’s 
close box. Depending on the kind of document that you’re working with and the work that has
done, one of the following situations will arise.

Closing a New Template

If you’re closing a new template that has not been edited, the document is closed immediate

If you’re closing a new template to which changes have been made, Informed Designer will w
you to save the changes:

Closing a Template
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If you’re using a Mac OS compatible computer, the button names on this dialog box will be d
ent. Instead of ‘Yes’, you’ll see ‘Save’, and instead of ‘No’, you’ll see ‘Don’t Save.’ Clicking the
‘Yes’/’Save’ button displays the Save dialog box. If you’re using a Windows compatible comp
you’ll see the standard Windows Save dialog box.

Type the name of the new template and select the location to store it, then click ‘OK.’

If you’re using a Mac OS compatible computer, you’ll see the standard Mac OS Save dialog 

Type the name of the new template and select the location to store it, then click ‘Save.’ Clicki
‘Cancel’ instead cancels the Close command and your template document remains open.
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If a document with the name you specify already exists at the selected location, Informed De
will warn you with options to replace the existing document or cancel the Close command.

Clicking ‘No’/‘Don’t Save’ closes the template without saving any of the work you’ve done. Cl
ing ‘Cancel’ cancels the Close command and your template remains open.

Closing an Existing Template

When you close an existing template (that is, a document that was previously opened), Infor
Designer first checks to see if you’ve made changes to the template. If your template has no
changed since you last opened it, then it’s closed immediately without warning.

However, if you’ve made changes to the template, you’ll be asked if you want to save the cha

If you’re using a Windows compatible computer, the button names on this dialog box will be d
ent. Instead of ‘Save’, you’ll see ‘Yes’, and instead of ‘Don’t Save’, you’ll see ‘No.’ Click ‘Yes’/
‘Save’ to save the changes and close the template. Click ‘No’/‘Don’t Save’ to discard the cha
and close the template. Click ‘Cancel’ to cancel the Close command and continue editing you
plate.

Saving a Template
The Save command saves the currently active template—that is, the document that correspo
the front-most drawing window on your screen. This command is available only when change
have been made to the currently active template.

To save a template, select Save from the File menu. If the template corresponds to an existing d
ument (that is, it has been saved at least once before), it will be saved without warning.

If you’re saving a new template for the first time, you’ll be asked to name the template and sp
the location to store it. Depending on which operating system you’re using, you’ll see either t
standard Windows Save dialog box or the standard Mac OS Save dialog box (see “Closing a
Template” earlier).

Saving a Template
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Type the name of the new template and select the location to store it, then click ‘OK’ or ‘Save
Clicking ‘Cancel’ instead cancels the Save command.

If a document with the name you specify already exists at the selected location, Informed De
will warn you with options to replace the existing document or cancel the Save command.

Saving Copies of a Template
Use the Save As command to save a copy of a template with a different name, or at a differe
tion.

Choose Save As... from the File menu. If you’re using a Windows compatible computer, you’ll s
the standard Windows Save dialog box.

If you’re using a Mac OS compatible computer, you’ll see the following dialog box.

Saving Copies of a Template
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The same options apply as when saving a new document. After saving the new template doc
Informed Designer will automatically close the original template. The new document will rem
open for editing.

Template translation plug-ins allow you to save a template in different formats. If you have an
template translation plug-ins installed in your plug-ins folder, you’ll see those options in the ‘D
ument Type’ drop-down list.
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